THIẾT KẾ, TRIỂN KHAI HỆ THỐNG MẠNG KẾT HỢP IPV4 & IPV6. Phần 2

0
2235
Phân hoạc IP 1
Phân hoạc IP 2

 Gán địa chỉ IP

* Gán địa chỉ Ipv6

– Tại Core1

Core2 (config)# ipv6 unicast-routing

Core2 (config)# interface FastEthernet0/1

Core1(config-if)# ipv6 address 2018:1::1/64

Core1(config-if)# no shutdown

Core1(config-if)# exit

!

Core2 (config)# interface FastEthernet0/1.2

Core1(config-if)# ipv6 address 2018:2::1/64

Core1(config-if)# no shutdown

Core1(config-if)# exit

!

Core2 (config)# interface FastEthernet0/1.3

Core1(config-if)# ipv6 address 2018:3::1/64

Core1(config-if)# no shutdown

Core1(config-if)# exit

!

Core2 (config)# interface FastEthernet0/1.4

Core1(config-if)# ipv6 address 2018:4::1/64

Core1(config-if)# no shutdown

Core1(config-if)# exit

!

Core2 (config)# interface FastEthernet0/1.5

Core1(config-if)# ipv6 address 2018:5::1/64

Core1(config-if)# no shutdown

Core1(config-if)# exit

!

Core2 (config)# interface FastEthernet0/1.6

Core1(config-if)# ipv6 address 2018:6::1/64

Core1(config-if)# no shutdown

Core1(config-if)# exit

!

Core2 (config)# interface FastEthernet0/1.7

Core1(config-if)# ipv6 address 2018:7::1/64

Core1(config-if)# no shutdown

Core1(config-if)# exit

!

Core2 (config)# interface Serial0/0/0

Core1(config-if)# ipv6 address 2018:B::1/126

Core1(config-if)# no shutdown

Core1(config-if)# exit

!

Core2 (config)# interface Serial0/1/0

Core1(config-if)# ipv6 address 2018:A::1/126

Core1(config-if)# no shutdown

Core1(config-if)# exit

– Tại Core2

Core2 (config)# ipv6 unicast-routing

Core2 (config)# interface FastEthernet0/1

Core1(config-if)# ipv6 address 2018:1::2/64

Core1(config-if)# no shutdown

Core1(config-if)# exit

!

Core2 (config)# interface FastEthernet0/1.2

Core1(config-if)# ipv6 address 2018:2::2/64

Core1(config-if)# no shutdown

Core1(config-if)# exit

!

Core2 (config)# interface FastEthernet0/1.3

Core1(config-if)# ipv6 address 2018:3::2/64

Core1(config-if)# no shutdown

Core1(config-if)# exit

!

Core2 (config)# interface FastEthernet0/1.4

Core1(config-if)# ipv6 address 2018:4::2/64

Core1(config-if)# no shutdown

Core1(config-if)# exit

!

Core2 (config)# interface FastEthernet0/1.5

Core1(config-if)# ipv6 address 2018:5::2/64

Core1(config-if)# no shutdown

Core1(config-if)# exit

!

Core2 (config)# interface FastEthernet0/1.6

Core1(config-if)# ipv6 address 2018:6::2/64

Core1(config-if)# no shutdown

Core1(config-if)# exit

!

Core2 (config)# interface FastEthernet0/1.7

Core1(config-if)#ipv6 address 2018:7::2/64

Core1(config-if)# no shutdown

Core1(config-if)# exit

!

Core2 (config)# interface Serial0/0/0

Core1(config-if)#ipv6 address 2018:B::1/126

Core1(config-if)# no shutdown

Core1(config-if)# exit

!

Core2 (config)# interface Serial0/1/0

Core1(config-if)#ipv6 address 2018:A::1/126

Core1(config-if)# no shutdown

Core1(config-if)# exit

* Gán địa chỉ IPV4

Tại Edge1

Edge1 (config)# interface FastEthernet0/0

Edge1(config-if)# ip address 192.168.1.1 255.255.255.0

Edge1(config-if)# no shutdown

Edge1(config-if)# exit

!

Edge1 (config)# interface Serial0/0/0

Edge1(config-if)# ip address 203.165.10.10 255.255.255.248

Edge1(config-if)# no shutdown

Edge1(config-if)# exit

– Tại Edge2

Edge2 (config)# interface Serial0/0/0

Edge2(config-if)# ip address 203.165.10.17 255.255.255.248

Edge2(config-if)# no shutdown

Edge2(config-if)# exit

– Tại Vigor Primary

Vigor Primary (config)# interface Serial0/0/0

Vigor Primary (config-if)# ip address 200.100.100.33 255.255.255.248

Vigor Primary (config-if)# no shutdown

Vigor Primary (config-if)# exit

– Tại Vigor Backup

Vigor Backup (config)# interface Serial0/0/0

Vigor Backup (config-if)# ip address 203.165.10.26 255.255.255.248

Vigor Backup (config-if)# no shutdown

Vigor Backup (config-if)# exit

3.1.3. Cấu hình và gán địa chỉ IPv6 cho Vlan:

* Cấu hình Vlan:

– Tại Distribute1

Distribute1(config)#vlan 2

Distribute1(config-vlan)#name wifi

Distribute1(config-vlan)#exit

!

Distribute1(config)#vlan 3

Distribute1(config-vlan)#name ketoan

Distribute1(config-vlan)#exit

Distribute1(config)#vlan 4

Distribute1(config-vlan)#name cntt

Distribute1(config-vlan)#exit

!

Distribute1(config)#vlan 5

Distribute1(config-vlan)#name kythuat

Distribute1(config-vlan)#exit

!

Distribute1(config)#vlan 6

Distribute1(config-vlan)#name serverfarm

Distribute1(config-vlan)#exit

!

Distribute1(config)#vlan 7

Distribute1(config-vlan)#name TCHC

Distribute1(config-vlan)#exit

– Tại Distribute 2

Distribute2(config)#vlan 2

Distribute2(config-vlan)#name wifi

Distribute2(config-vlan)#exit

Distribute2(config)#vlan 3

Distribute2(config-vlan)#name ketoan

Distribute2(config-vlan)#exit

Distribute2(config)#vlan 4

Distribute2(config-vlan)#name cntt

Distribute2(config-vlan)#exit

Distribute2(config)#vlan 5

Distribute2(config-vlan)#name kythuat

Distribute2(config-vlan)#exit

!

Distribute2(config)#vlan 6

Distribute2(config-vlan)#name serverfarm

Distribute2(config-vlan)#exit

!

Distribute2(config)#vlan 7

Distribute2(config-vlan)#name TCHC

Distribute2(config-vlan)#exit

* Gán địa chỉ IPv6 cho Vlan:

– Tại Distribute1

Distribute1(config)# interface FastEthernet0/1.2

Distribute1(config-if)# encapsulation dot1Q 2

Distribute1(config-if)# ipv6 address FE80::2 link-local

Distribute1(config-if)# ipv6 address 2018:2::1/64

Distribute1(config-if)# exit

!

Distribute1(config)# interface FastEthernet0/1.3

Distribute1(config-if)# encapsulation dot1Q 3

Distribute1(config-if)# ipv6 address FE80::3 link-local

Distribute1(config-if)# ipv6 address 2018:3::1/64

Distribute1(config-if)# exit

!

Distribute1(config)# interface FastEthernet0/1.4

Distribute1(config-if)# encapsulation dot1Q 4

Distribute1(config-if)# ipv6 address FE80::4 link-local

Distribute1(config-if)# ipv6 address 2018:4::1/64

Distribute1(config-if)# exit

!

Distribute1(config)# interface FastEthernet0/1.5

Distribute1(config-if)# encapsulation dot1Q 5

Distribute1(config-if)# ipv6 address FE80::5 link-local

Distribute1(config-if)# ipv6 address 2018:5::1/64

Distribute1(config-if)# exit

!

Distribute1(config)# interface FastEthernet0/1.6

Distribute1(config-if)# encapsulation dot1Q 6

Distribute1(config-if)# ipv6 address FE80::6 link-local

Distribute1(config-if)# ipv6 address 2018:6::1/64

Distribute1(config-if)# exit

!

Distribute1(config)# interface FastEthernet0/1.7

Distribute1(config-if)# encapsulation dot1Q 7

Distribute1(config-if)# ipv6 address FE80::7 link-local

Distribute1(config-if)# ipv6 address 2018:7::1/64

Distribute1(config-if)# exit

– Tại Distribute2

Distribute2(config)# interface FastEthernet0/1

Distribute2(config-if)# ipv6 address 2018:1::2/64

Distribute2(config-if)# ipv6 enable

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/1.2

Distribute2(config-if)# encapsulation dot1Q 2

Distribute2(config-if)# ipv6 address FE80::2 link-local

Distribute2(config-if)# ipv6 address 2018:2::2/6

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/1.3

Distribute2(config-if)# encapsulation dot1Q 3

Distribute2(config-if)# ipv6 address FE80::3 link-local

Distribute2(config-if)# ipv6 address 2018:3::2/64

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/1.4

Distribute2(config-if)# encapsulation dot1Q 4

Distribute2(config-if)# ipv6 address FE80::4 link-local

Distribute2(config-if)# ipv6 address 2018:4::2/64

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/1.5

Distribute2(config-if)# encapsulation dot1Q 5

Distribute2(config-if)# ipv6 address FE80::5 link-local

Distribute2(config-if)# ipv6 address 2018:5::2/64

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/1.6

Distribute2(config-if)# encapsulation dot1Q 6

Distribute2(config-if)# ipv6 address FE80::6 link-local

Distribute2(config-if)# ipv6 address 2018:6::6/64

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/1.7

Distribute2(config-if)# encapsulation dot1Q 7

Distribute2(config-if)# ipv6 address FE80::7 link-local

Distribute2(config-if)# ipv6 address 2018:7::2/64

Distribute2(config-if)# exit

!

Distribute2(config)# interface Serial0/0/0

Distribute2(config-if)# ipv6 address 2018:B::1/126

3.2. Cấu hình Switchport Trunking

– Tại Distribute1

Distribute1(config)# interface Port-channel1

Distribute1(config-if)# switchport trunk encapsulation dot1q

Distribute1(config-if)# switchport mode trunk

Distribute1(config-if)# exit

!

Distribute1(config)# interface FastEthernet0/2

Distribute1(config-if)# switchport trunk encapsulation dot1q

Distribute1(config-if)# switchport mode trunk

Distribute1(config-if)# exit

!

Distribute1(config)# interface FastEthernet0/3

Distribute1(config-if)# switchport trunk encapsulation dot1q

Distribute1(config-if)# switchport mode trunk

Distribute1(config-if)# exit

!

Distribute1(config)# interface FastEthernet0/4

Distribute1(config-if)# switchport trunk encapsulation dot1q

Distribute1(config-if)# switchport mode trunk

Distribute1(config-if)# exit

!

Distribute1(config)# interface FastEthernet0/5

Distribute1(config-if)# switchport trunk encapsulation dot1q

Distribute1(config-if)# switchport mode trunk

Distribute1(config-if)# exit

!

Distribute1(config)# interface FastEthernet0/6

Distribute1(config-if)# switchport trunk encapsulation dot1q

Distribute1(config-if)# switchport mode trunk

Distribute1(config-if)# exit

!

Distribute1(config)# interface FastEthernet0/7

Distribute1(config-if)# switchport trunk encapsulation dot1q

Distribute1(config-if)# switchport mode trunk

Distribute1(config-if)# exit

!

Distribute1(config)# interface FastEthernet0/8

Distribute1(config-if)# switchport trunk encapsulation dot1q

Distribute1(config-if)# switchport mode trunk

Distribute1(config-if)# exit

!

Distribute1(config)# interface FastEthernet0/9

Distribute1(config-if)# switchport trunk encapsulation dot1q

Distribute1(config-if)# switchport mode trunk

Distribute1(config-if)# exit

!

Distribute1(config)# interface FastEthernet0/10

Distribute1(config-if)# switchport trunk encapsulation dot1q

Distribute1(config-if)# switchport mode trunk

Distribute1(config-if)# exit

!

Distribute1(config)# interface FastEthernet0/11

Distribute1(config-if)# switchport trunk encapsulation dot1q

Distribute1(config-if)# switchport mode trunk

Distribute1(config-if)# exit

!

Distribute1(config)# interface FastEthernet0/12

Distribute1(config-if)# switchport trunk encapsulation dot1q

Distribute1(config-if)# switchport mode trunk

Distribute1(config-if)# exit

!

Distribute1(config)# interface GigabitEthernet0/1

Distribute1(config-if)# switchport trunk encapsulation dot1q

Distribute1(config-if)# switchport mode trunk

Distribute1(config-if)# exit

– Tại Distribute2

Distribute2(config)# interface Port-channel1

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/1

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/2

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/3

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/4

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/5

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/6

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/7

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/8

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/9

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/10

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/11

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/12

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/13

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/14

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/15

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/16

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/17

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/18

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/19

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/20

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/21

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/22

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/23

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# channel-group 1 mode on

Distribute2(config-if)# exit

!

Distribute2(config)# interface FastEthernet0/24

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# channel-group 1 mode on

Distribute2(config-if)# exit

!

Distribute2(config-if)# interface GigabitEthernet0/1

Distribute2(config-if)# switchport trunk encapsulation dot1q

Distribute2(config-if)# switchport mode trunk

Distribute2(config-if)# exit

3.3. Cấu hình VTP domain

* Cấu hình VTP Server

– Tại Distribute1

Distribute1(config)#vtp mode server

Device mode already VTP SERVER.

Distribute1(config)#vtp domain donga.com

Domain name already set to donga.com.

Distribute1(config)#vtp password 123

Password already set to 123

– Tại Distribute2

Distribute2(config)#vtp mode server

Device mode already VTP SERVER.

Distribute2(config)#vtp domain donga.com

Domain name already set to donga.com.

Distribute2(config)#vtp password 123

Password already set to 123

* Cấu hình VTP Client

– Tại Distribute1

Distribute1(config)#vtp mode client

Device mode already VTP CLIENT.

Distribute1(config)#vtp domain donga.com

Domain name already set to donga.com.

Distribute1(config)#vtp password 123

Password already set to 123

– Tại Distribute2

Distribute2(config)#vtp mode client

Device mode already VTP CLIENT.

Distribute2(config)#vtp domain donga.com

Domain name already set to donga.com.

Distribute2(config)#vtp password 123

Password already set to 123

3.4. Cấu hình DHCP

*Cấu hình DHCP

– Core1

Core1 (config)# ipv6 unicast-routing

Core1(config-dhcpv6)# ipv6 dhcp pool donga4

Core1(config-dhcpv6)# prefix-delegation pool vlan4

Core1(config-dhcpv6)# dns-server 2018:6::2

Core1(config-dhcpv6)# exit

!

Core1 (config)# ipv6 dhcp pool donga6

Core1(config-dhcpv6)# prefix-delegation pool vlan6

Core1(config-dhcpv6)# dns-server 2018:6::2

Core1(config-dhcpv6)# exit

!

Core1(config-dhcpv6)# ipv6 dhcp pool donga2

Core1(config-dhcpv6)# prefix-delegation pool vlan2

Core1(config-dhcpv6)# dns-server 2018:6::2

Core1(config-dhcpv6)# exit

!

Core1 (config)# ipv6 dhcp pool donga3

Core1(config-dhcpv6)# prefix-delegation pool vlan3

Core1(config-dhcpv6)# dns-server 2018:6::2

Core1(config-dhcpv6)# exit

Core1 (config)# ipv6 dhcp pool donga5

Core1(config-dhcpv6)# prefix-delegation pool vlan5

Core1(config-dhcpv6)# dns-server 2018:6::2

Core1(config-dhcpv6)# exit

!

Core1 (config)# ipv6 dhcp pool donga7

Core1(config-dhcpv6)# prefix-delegation pool vlan7

Core1(config-dhcpv6)# dns-server 2018:6::2

– Core2

Core2 (config)# ip cef

Core2 (config)# ipv6 unicast-routing

!

Core2 (config)# ipv6 cef

!

Core2 (config)# ipv6 dhcp pool donga4

Core1(config-dhcpv6)# prefix-delegation pool vlan4

Core1(config-dhcpv6)# dns-server 2018:6::2

Core1(config-dhcpv6)# exit

!

Core2 (config)# ipv6 dhcp pool donga6

Core1(config-dhcpv6)# prefix-delegation pool vlan6

Core1(config-dhcpv6)# dns-server 2018:6::2

Core1(config-dhcpv6)# exit

!

Core2 (config)# ipv6 dhcp pool donga2

Core2 (config)# prefix-delegation pool vlan2

Core2 (config)# dns-server 2018:6::2

Core1(config-dhcpv6)# exit

!

Core2 (config)# ipv6 dhcp pool donga3

Core2 (config)# prefix-delegation pool vlan3

Core2 (config)# dns-server 2018:6::2

Core1(config-dhcpv6)# exit

!

Core2 (config)# ipv6 dhcp pool donga5

Core2 (config)# prefix-delegation pool vlan5

Core2 (config)# dns-server 2018:6::2

Core1(config-dhcpv6)# exit

!

Core2 (config)# ipv6 dhcp pool donga7

Core2 (config)# prefix-delegation pool vlan7

Core2 (config)# dns-server 2018:6::2

Core1(config-dhcpv6)# exit

* Cấu hình cấp IP cho các Vlan

– Core 1

Core1 (config)# ipv6 unicast-routing

Core1 (config)# ipv6 local pool vlan6 2018:6::/64 64

Core1 (config)# ipv6 local pool vlan2 2018:2::/64 64

Core1 (config)# ipv6 local pool vlan3 2018:3::/64 64

Core1 (config)# ipv6 local pool vlan4 2018:4::/64 64

Core1 (config)# ipv6 local pool vlan5 2018:5::/64 64

Core1 (config)# ipv6 local pool vlan7 2018:7::/64 64

– Core 2

Core2 (config)# ipv6 local pool vlan6 2018:6::/64 64

Core2 (config)# ipv6 local pool vlan2 2018:2::/64 64

Core2 (config)# ipv6 local pool vlan3 2018:3::/64 64

Core2 (config)# ipv6 local pool vlan4 2018:4::/64 64

Core2 (config)# ipv6 local pool vlan5 2018:5::/64 64

Core2 (config)# ipv6 local pool vlan7 2018:7::/64 64

3.5. Cấu hình Frame relay và OSPF

* Cấu hình frame relay

– Tại ISP1

ISP1 (config)# interface Serial0/0/1

ISP1 (config-if)# encapsulation frame-relay ietf

ISP1 (config-if)# frame-relay lmi-type ansi

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP1 (config)# interface Serial0/0/1.102 point-to-point

ISP1 (config-if)# ip address 200.100.1.1 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 102

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP1 (config)# interface Serial0/0/1.103 point-to-point

ISP1 (config-if)# ip address 200.100.1.5 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 103

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP1 (config)# interface Serial0/0/1.104 point-to-point

ISP1 (config-if)# ip address 200.100.1.9 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 104

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP1 (config)# interface Serial0/0/1.105 point-to-point

ISP1 (config-if)# ip address 200.100.1.13 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 105

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

– Tại ISP2

ISP2 (config)# interface Serial0/0/1

ISP1 (config-if)# encapsulation frame-relay ietf

ISP1 (config-if)# frame-relay lmi-type ansi

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP2 (config)#interface Serial0/0/1.201 point-to-point

ISP1 (config-if)# ip address 200.100.1.2 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 201

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP2 (config)#interface Serial0/0/1.203 point-to-point

ISP1 (config-if)# ip address 200.100.1.17 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 203

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP2 (config)# interface Serial0/0/1.204 point-to-point

ISP1 (config-if)# ip address 200.100.1.21 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 204

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP2 (config)#interface Serial0/0/1.205 point-to-point

ISP1 (config-if)# ip address 200.100.1.25 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 205

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

– Tại ISP3

ISP3 (config)# interface Serial0/0/1

ISP1 (config-if)# encapsulation frame-relay ietf

ISP1 (config-if)# frame-relay lmi-type ansi

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP3 (config)#interface Serial0/0/1.301 point-to-point

ISP1 (config-if)# ip address 200.100.1.6 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 301

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP3 (config)#interface Serial0/0/1.302 point-to-point

ISP1 (config-if)# ip address 200.100.1.18 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 302

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP3 (config)#interface Serial0/0/1.304 point-to-point

ISP1 (config-if)# ip address 200.100.1.29 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 304

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP3 (config)#interface Serial0/0/1.305 point-to-point

ISP1 (config-if)# ip address 200.100.1.33 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 305

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

– Tại ISP4

ISP4 (config)# interface Serial0/0/1

ISP1 (config-if)# encapsulation frame-relay ietf

ISP1 (config-if)# frame-relay lmi-type ansi

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP4 (config)#interface Serial0/0/1.401 point-to-point

ISP1 (config-if)# ip address 200.100.1.10 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 401

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP4 (config)# interface Serial0/0/1.402 point-to-point

ISP1 (config-if)# ip address 200.100.1.22 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 402

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP4 (config)#interface Serial0/0/1.403 point-to-point

ISP1 (config-if)# ip address 200.100.1.30 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 403

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP4 (config)#interface Serial0/0/1.405 point-to-point

ISP1 (config-if)# ip address 200.100.1.37 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 405

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

– Tại ISP5

ISP5 (config)# interface Serial0/0/1

ISP1 (config-if)# encapsulation frame-relay ietf

ISP1 (config-if)# frame-relay lmi-type ansi

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP5 (config)#interface Serial0/0/1.501 point-to-point

ISP1 (config-if)# ip address 200.100.1.14 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 501

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP5 (config)#interface Serial0/0/1.502 point-to-point

ISP1 (config-if)# ip address 200.100.1.26 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 502

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP5 (config)# interface Serial0/0/1.503 point-to-point

ISP1 (config-if)# ip address 200.100.1.34 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 503

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

!

ISP5 (config)#interface Serial0/0/1.504 point-to-point

ISP1 (config-if)# ip address 200.100.1.38 255.255.255.252

ISP1 (config-if)# frame-relay interface-dlci 504

ISP1 (config-if)# no shutdown

ISP1 (config-if)# exit

* Cấu hình Frame Relay

TT

From Port

Sublink

To Port

Sublink

1

Serial 1

S1-S2

Serial 2

S2-S1

2

Serial 1

S1-S3

Serial 3

S3-S1

3

Serial 1

S1-S4

Serial 4

S4-S1

4

Serial 1

S1-S5

Serial 5

S5-S1

5

Serial 2

S2-S3

Serial 3

S3-S2

6

Serial 2

S2-S4

Serial 4

S4-S2

7

Serial 2

S2-S5

Serial 5

S5-S2

8

Serial 3

S3-S4

Serial 4

S4-S3

9

Serial 3

S3-S4

Serial 5

S5-S3

10

Serial 4

S4-S5

Serial 5

S5-S4

Kết quả sau khi cấu hình và kết nối các frame relay của các ISP

* Cấu hình OSPF trong frame relay

– Tại ISP1

ISP1 (config)# router ospf 100

ISP1 (config-router)# network 203.165.10.32 0.0.0.7 area 0

ISP1 (config-router)# network 200.100.1.0 0.0.0.255 area 0

ISP1 (config-router)# exit

– Tại ISP2

ISP2 (config)# router ospf 100

ISP1 (config-router)# network 200.100.1.0 0.0.0.255 area 0

ISP1 (config-router)# network 203.165.10.8 0.0.0.7 area 0

ISP1 (config-router)# exit

– Tại ISP3

ISP3 (config)# router ospf 100

ISP1 (config-router)# network 200.100.1.0 0.0.0.255 area 0

ISP1 (config-router)# network 203.165.10.16 0.0.0.7 area 0

ISP1 (config-router)# exit

– Tại ISP4

ISP4 (config)# router ospf 100

ISP1 (config-router)# network 200.100.1.0 0.0.0.255 area 0

ISP1 (config-router)# network 203.165.10.24 0.0.0.7 area 0

ISP1 (config-router)# exit

– ISP5

ISP5 (config)# router ospf 100

ISP1 (config-router)# network 200.100.1.0 0.0.0.255 area 0

ISP1 (config-router)# network 203.165.10.24 0.0.0.7 area 0

ISP1 (config-router)# exit

3.6. NAT IPv4

– Tại Edge1

Edge1 (config)# interface FastEthernet0/0

Edge1 (config-if)# ip address 192.168.1.1 255.255.255.0

Edge1 (config-if)# ip nat inside

Edge1 (config-if)# no shutdown

Edge1 (config-if)# exit

!

Edge1 (config)# interface Serial0/0/0

Edge1 (config-if)# ip address 203.165.10.10 255.255.255.248

Edge1 (config-if)# ip nat outside

Edge1 (config-if)# no shutdown

Edge1 (config-if)# exit

!

Edge1 (config)# ip nat inside source list 1 interface Serial0/0/0 overload

Edge1 (config)# access-list 1 permit 192.168.1.0 0.0.0.255

– Tại Vigor Primary

Vigor Primary (config)# interface Serial0/0/0

Vigor Primary (config-if)# ip address 203.165.10.33 255.255.255.248

Vigor Primary (config-if)# ipv6 nat

Vigor Primary (config-if)# exit

!

Vigor Primary (config)# interface Serial0/0/1

Vigor Primary (config-if)# no ip address

Vigor Primary (config-if)# ipv6 address 2018:A::2/126

Vigor Primary (config-if)# ipv6 nat prefix 2018::/96 v4-mapped pool_to_ipv4

Vigor Primary (config-if)# ipv6 nat

Vigor Primary (config-if)# exit

!

Vigor Primary (config)# ip route 0.0.0.0 0.0.0.0 203.165.10.34

Vigor Primary (config)# exit

!

Vigor Primary (config)# ip access-list extended list_ipv4

VigorPrimary(config-ext-nacl)# permit ip any host 203.165.10.35

VigorPrimary(config-ext-nacl)# exit

!

Vigor Primary (config)# ipv6 nat v6v4 source 2018:6::3 203.165.10.35

Vigor Primary (config)# ipv6 nat v4v6 source list list_ipv4 pool pool_ipv4

Vigor Primary (config)# ipv6 nat v6v4 source list list_ipv4 pool pool_to_ipv4

Vigor Primary (config)# ipv6 nat v6v4 source list list_to_ipv4 interface Serial0/0/0 overload

Vigor Primary (config)# ipv6 nat v4v6 pool pool_ipv4 2018::1 2018::3 prefix-length 96

Vigor Primary (config)# ipv6 nat prefix 2018::/96

!

Vigor Primary (config)# ipv6 access-list list_to_ipv4

VigorPrimary(config-ext-nacl)# permit ipv6 2018:A::/126 any

VigorPrimary(config-ext-nacl)# permit ipv6 2018:3::/64 any

VigorPrimary(config-ext-nacl)# permit ipv6 2018:1::/64 any

VigorPrimary(config-ext-nacl)# permit ipv6 2018:2::/64 any

VigorPrimary(config-ext-nacl)# permit ipv6 2018:4::/64 any

VigorPrimary(config-ext-nacl)# permit ipv6 2018:5::/64 any

VigorPrimary(config-ext-nacl)# permit ipv6 2018:6::/64 any

VigorPrimary(config-ext-nacl)# permit ipv6 2018:7::/64 any

VigorPrimary(config-ext-nacl)# exit

!

Vigor Primary (config)# ipv6 access-list pool_to_ipv4

VigorPrimary(config-ext-nacl)# permit ipv6 any 2018::/96

VigorPrimary(config-ext-nacl)# exit

– Tại Vigor Backup

Vigor Backup (config)# interface GigabitEthernet0/0

Vigor Backup (config-if)# ipv6 address FE80::5:73FF:FEA0:400 link-local

Vigor Backup (config-if)# ipv6 address 2018:C::2/64

Vigor Backup (config-if)# ipv6 nat prefix 2018::/96 v4-mapped pool_to_ipv4

Vigor Backup (config-if)# ipv6 nat

Vigor Backup (config-if)# ipv6 enable

Vigor Backup (config-if)# no shutdown

Vigor Backup (config-if)# exit

!

Vigor Backup (config)# interface Serial0/0/0

Vigor Backup (config-if)# ip address 203.165.10.26 255.255.255.248

Vigor Backup (config-if)# ipv6 nat

Vigor Backup (config-if)# no shutdown

Vigor Backup (config-if)# exit

!

Vigor Backup (config)# interface Serial0/0/1

Vigor Backup (config-if)# ipv6 address 2018:B::2/126

Vigor Backup (config-if)# ipv6 nat prefix 2018::/96 v4-mapped pool_to_ipv4

Vigor Backup (config-if)# ipv6 nat

Vigor Backup (config-if)# no shutdown

Vigor Backup (config-if)# exit

!

Vigor Backup (config)# ip route 0.0.0.0 0.0.0.0 203.165.10.25

!

Vigor Backup (config)# ipv6 route ::/0 2018:10::2

!

Vigor Backup (config)# ipv6 nat v4v6 source list list_ipv4 pool pool_ipv4

Vigor Backup (config)# ipv6 nat v6v4 source list list_ipv4 pool pool_ipv4

Vigor Backup (config)# ipv6 nat v6v4 source list list_to_ipv4 interface Serial0/0/0 overload

Vigor Backup (config)# ipv6 nat prefix 2018::/96

Vigor Backup (config)# ipv6 access-list list_to_ipv4

Vigor Backup (config-ext-nacl)# permit ipv6 2018:3::/64 any

Vigor Backup (config-ext-nacl)# permit ipv6 2018:1::/64 any

Vigor Backup (config-ext-nacl)# permit ipv6 2018:4::/64 any

Vigor Backup (config-ext-nacl)# permit ipv6 2018:5::/64 any

Vigor Backup (config-ext-nacl)# permit ipv6 2018:6::/64 any

Vigor Backup (config-ext-nacl)# permit ipv6 2018:7::/64 any

Vigor Backup (config-ext-nacl)# permit ipv6 2018:B::/126 any

Vigor Backup (config-ext-nacl)# permit ipv6 2018:C::/64 any

Vigor Backup (config-ext-nacl)# exit

Vigor Backup (config)# ipv6 access-list pool_to_ipv4

Vigor Backup (config-ext-nacl)#l permit ipv6 any 2018::/96

– Tại Edge2

Edge2 (config)# interface FastEthernet0/0

Edge2 (config-if)# ipv6 address 2018:30::1/64

Edge2 (config-if)# ipv6 nat prefix 2018::/96 v4-mapped pool_to_ipv4

Edge2 (config-if)# ipv6 nat

Edge2 (config-if)# ipv6 enable

Edge2 (config-if)# exit

!

Edge2 (config)# interface Serial0/0/0

Edge2 (config-if)# ip address 203.165.10.17 255.255.255.248

Edge2 (config-if)# ipv6 nat

Edge2 (config-if)# exit

!

Edge2 (config)# ipv6 route ::/0 2018:10::1

!

Edge2 (config)# ip access-list extended list_ipv4

Edge2 (config-ext-nacl)# permit ip any host 203.165.10.19

Edge2 (config-ext-nacl)# permit ip any host 203.165.10.20

Edge2 (config-ext-nacl)# permit ip any host 203.165.10.21

Edge2 (config-ext-nacl)# exit

!

Edge2 (config)# ipv6 nat v6v4 source 2018:30::2 203.165.10.19

Edge2 (config)# ipv6 nat v6v4 source 2018:30::3 203.165.10.20

Edge2 (config)# ipv6 nat v6v4 source 2018:30::4 203.165.10.21

Edge2 (config)# ipv6 nat v4v6 source list list_ipv4 pool pool_ipv4

Edge2 (config)# ipv6 nat v6v4 source list list_ipv4 pool pool_to_ipv4

Edge2 (config)# ipv6 nat v6v4 source list list_to_ipv4 interface Serial0/0/0 overload

Edge2 (config)# ipv6 nat prefix 2018::/96

!

Edge2 (config)# ipv6 access-list list_to_ipv4

Edge2 (config-ext-nacl)# permit ipv6 2018:30::/64 any

Edge2 (config-ext-nacl)# exit

!

Edge2 (config-ext-nacl)# ipv6 access-list pool_to_ipv4

Edge2 (config-ext-nacl)# permit ipv6 any 2018::/96

Edge2 (config-ext-nacl)# exit

3.7. Tunnel

* Cấu hình Tunnel

Tại Vigor Backup

Vigor Backup (config)# interface Tunnel12

Vigor Backup (config-if)# ipv6 address 2018:10::1/64

Vigor Backup (config-if)# ipv6 enable

Vigor Backup (config-if)# tunnel source Serial0/0/0

Vigor Backup (config-if)# tunnel destination 203.165.10.17

Vigor Backup (config-if)# tunnel mode ipv6ip

Vigor Backup (config-if)# exit

– Tại Edge2

Edge2 (config)# interface Tunnel12

Edge2 (config-if)# ipv6 address 2018:10::2/64

Edge2 (config-if)# ipv6 enable

Edge2 (config-if)# ipv6 ospf 1 area 0

Edge2 (config-if)# tunnel source Serial0/0/0

Edge2 (config-if)# tunnel destination 203.165.10.26

Edge2 (config-if)# tunnel mode ipv6ip

Edge2 (config-if) # exit

3.8. HSRP

* Cấu hình HSRP

– Vigor Backup

Vigor Backup (config)# interface GigabitEthernet0/0

Vigor Backup (config-if)# ip address 172.20.2.2 255.255.0.0

Vigor Backup (config-if) # standby version 2

Vigor Backup (config-if)# standby 2 ip 172.20.20.20

Vigor Backup (config-if)# standby 2 preempt

Vigor Backup (config-if)# standby 1 ipv6 autoconfig

Vigor Backup (config-if)# standby 1 preempt

Vigor Backup (config-if)# exit

– Vigor Primary

Vigor Primary (config)# interface GigabitEthernet0/0

Vigor Primary (config-if)# ip address 172.20.1.1 255.255.0.0

Vigor Primary (config-if)# ipv6 nat

Vigor Primary (config-if)# ipv6 enable

Vigor Primary (config-if)# standby version 2

Vigor Primary (config-if)# standby 2 ip 172.20.20.20

Vigor Primary (config-if)# standby 2 priority 120

Vigor Primary (config-if)# standby 2 preempt

Vigor Primary (config-if)# exit

– Core 1

Core 1 (config)# interface FastEthernet0/0

Core 1 (config)# ip address 172.20.3.3 255.255.0.0

Core 1 (config)# ipv6 enable

Core 1 (config)# exit

– Core 2

Core 2 (config)# interface FastEthernet0/0

Core 2 (config)# ip address 172.20.4.4 255.255.0.0

Core 2 (config)# ipv6 enable

Core 2 (config)# exit

* Cấu hình Route

– Vigor Backup

Vigor Backup (config)# ip route 0.0.0.0 0.0.0.0 203.165.10.25

Vigor Backup (config)# ip route 0.0.0.0 0.0.0.0 203.165.10.25

– Vigor Primary

Vigor Primary (config)# ip route 0.0.0.0 0.0.0.0 203.165.10.34

– Core 1

Core 1 (config)# ip route 0.0.0.0 0.0.0.0 172.20.20.20

Core 1 (config)# ipv6 route ::/0 FastEthernet0/0 FE80::5:73FF:FEA0:1

– Core 2

Core 2 (config)# ip route 0.0.0.0 0.0.0.0 172.20.20.20

Core 2 (config)# ipv6 route ::/0 FastEthernet0/0 FE80::5:73FF:FEA0:1

Chúc bạn thành công

LEAVE A REPLY

Please enter your comment!
Please enter your name here